skule.sormo.no

ORG NR 885 947 522

Velkommen, gjester
Brukernavn: Passord: Secret Key Husk meg
  • Side:
  • 1

EMNE: Problem med oppgradering av PHP

Problem med oppgradering av PHP 5 år 6 måneder dager siden #15

  • Skule Sørmo
  • Skule Sørmo's profilbilde Topic Author
Ved installasjon av LAMP (Linux, Apache, MariaDB og PHP) på Centos v7.2, vil versjon 3.4.14 av PHP bli installert. Da blir ikke OPCache installert og en rekke andre PHP-moduler som trengs til Moodle. Oppgradering av PHP til v5.6 fører til at GNOME krasjer.

Løsning: Nyinstallasjon av Centos 7.2, deretter installere apache og mariadb. Så nyinstallasjon av PHP v 5.6. Tilleggsmoduler må også installeres, blant annet php56w-mysql for at MariaDB (Mysql) skal fungere. Modulene php56w-xmlrpc, php56w-xml, php56w-soap, php56w-opcache, php56w-mbstring, php56w-intl, php56w-gd må også installeres.

PHP v7 kan ikke brukes dersom video skal vises i Moodle og kategoribegrep brukes i Kunena. Da må PHP v5.6 brukes som fungerer i alle sammenhenger.

PHP v7 sies å være dobbelt så rask som v 5.6, men siden ikke alle funksjoner fungerer der, hjelper det lite..

Ikke installer alle modulene fra php70w, da vil GNOME krasje..

Ikke installer Samba der den tidligere Samba-versjonen fjernes. Da krasjer GNOME..

Please Logg inn eller Registrer konto to join the conversation.

Problem med oppgradering av PHP 4 år 3 uker dager siden #34

  • Skule Sørmo
  • Skule Sørmo's profilbilde Topic Author
PHP 7.0.24 er nå installert, og ingen problemer med Joomla og Moodle med den.

Please Logg inn eller Registrer konto to join the conversation.

  • Side:
  • 1
Tid til å lage siden: 0.051 sekunder